Specifications

Active version information

The active, latest version of LLBLGen Pro is v5.3, first released on October 13th, 2017.

Supported Databases

The LLBLGen Pro Designer supports the following relational databases. With every database system, the supported versions and which O/R mapper framework the database is supported on is specified.

Database Supported for O/R mapper
SQL Server
SQL Server 2000 or higher / Express / CE Desktop / SQL Azure
Entity Framework (Full / Core), Linq to SQL, LLBLGen Pro Runtime Framework, NHibernate
MS Access
MS Access 2000 or higher
LLBLGen Pro Runtime Framework
Oracle
Oracle 9i or higher
LLBLGen Pro Runtime Framework, NHibernate
Postgresql
PostgreSql 7.4+ or higher
Entity Framework (Full / Core), LLBLGen Pro Runtime Framework, NHibernate
Firebird
Firebird 1.5.x or higher
Entity Framework (Full), LLBLGen Pro Runtime Framework, NHibernate
DB2
IBM DB2 7.x or higher (not on AS/400 / iSeries)
Entity Framework (Full), LLBLGen Pro Runtime Framework, NHibernate
Mysql
MySql 4.x or higher (using DevArt MySql .NET provider)
Entity Framework (Full), LLBLGen Pro Runtime Framework, NHibernate

Supported Document Databases

Additionally to relational databases, the LLBLGen Pro Designer supports through its Derived Models feature the following NoSQL document databases: RavenDB, MongoDB and Microsoft Cosmos DB (previously DocumentDB).

Supported .NET versions

.NET 3.5, .NET 4.0, .NET 4.5.x, .NET 4.6.x, .NET 4.7.x, .NET Standard 1.6, .NET Standard 2.0. (.NET Core / Xamarin are supported through .NET Standard).

Supported O/R mapper frameworks

LLBLGen Pro Runtime Framework v5.3, Entity Framework v1-v6.x, Entity Framework Core v1-v2, NHibernate v3.x / v4.x, Linq to Sql

Supported .NET output languages

Code is generated in C# or VB.NET. Generated code can be used from any .NET language. Code is fully CLS compliant and VB.NET option explicit/strict compliant.

Why wait?

Become more productive today.

Buy now    Download Trial