Entity Framework (Full / Core)

Full Entity Framework Support

Utilize the full power of the LLBLGen Pro Designer when working with with your entity model: use reverse-engineering functionality (Database first) or Model first tools, or both at the same time. Easily synchronize your entity model with the database schemas, define and validate your entity model or create derived models on top of them and much more. You're in control.

Core, Code First or EDMX

Using the powerful template based code generator built into the LLBLGen Pro Designer you can generate code which targets Entity Framework Core (v1.x or v2.x), or the full Entity Framework version (v1 - v6.x). For the full Entity Framework version, you can choose between Code First mappings or EDMX mappings. You can switch between these choices at any time.

More than just an entity model

The entity model can be used as a basis for one or more derived models (which contain hierarchical definitions of derived elements from entity definitions) in denormalized form if required. You can use these derived models to produce DTO classes and, optionally, generate persistence code to automatically persist them as entity instances in your relational databases or document databases.

Code as if you have written it yourself

The code produced by the LLBLGen Pro Designer is carefully architected into two Visual Studio projects: one for your entity model classes and one for the persistence oriented code, like mappings and the DbContext class. All code is extensible through extension points, partial classes and partial methods, comes with XmlDoc comments to produce reference manuals, and is fully tested. You can start writing queries right away.

At a glance

Supported Databases

The LLBLGen Pro Designer supports the following relational databases for the various Entity Framework versions.

Database Supported for Entity Framework version
SQL Server
SQL Server 2000 or higher / Express / CE Desktop / SQL Azure
Entity Framework Core, Entity Framework v1-v6
Postgresql
PostgreSql 7.4 or higher
Entity Framework Core, Entity Framework v1-v6
Firebird
Firebird 1.5.x or higher
Entity Framework v1-v6
DB2
IBM DB2 7.x or higher (not on AS/400 / iSeries)
Entity Framework v1-v6
Mysql
MySql 4.x or higher (using DevArt MySql .NET provider)
Entity Framework v1-v6

Supported .NET versions

Entity Framework Full: .NET 4.5.x, .NET 4.6.x., .NET 4.7.x
Entity Framework Core v1: .NET 4.5.x, .NET 4.6.x., .NET 4.7.x, .NET Standard 1.6, .NET Standard 2.0
Entity Framework Core v2: .NET 4.6.1+, .NET 4.7.x, .NET Standard 2.0

Supported .NET output languages

Code is generated in C# or VB.NET, where for Entity Framework Core v1 code is generated in C# as it doesn't support VB.NET. Generated code can be used from any .NET language.

Why wait?

Become more productive today.

Buy now    Download Trial